Homebase Main Page Refresh Issue
Resolved·Partial outage

We have resolved the issue that was impacting some of our users. We apologize or any disruption this has caused.

Mon, Jun 16, 2025, 05:16 PM
(2 months ago)
·
Affected components
Web Application
Updates

Resolved

We have resolved the issue that was impacting some of our users. We apologize or any disruption this has caused.

Mon, Jun 16, 2025, 05:16 PM

Investigating

We have resolved the issue that was impacting some of our users. We apologize or any disruption this has caused.

Mon, Jun 16, 2025, 05:15 PM

Identified

Our engineers have identified the issue. A preliminary fix was applied to resolve refreshing, and a permanent issue is now being deployed.

Mon, Jun 16, 2025, 04:26 PM(49 minutes earlier)

Investigating

We are continuing to investigate this issue.

Mon, Jun 16, 2025, 02:28 PM(1 hour earlier)

Investigating

We are currently experiencing intermittent issues causing constant refreshing. We are actively working to resolve the issue and apologize for the inconvenience

Mon, Jun 16, 2025, 02:24 PM
Powered by

Status updates are published by our internal monitoring and incident response teams. For questions, contact support through your usual channel. Historical data and incident timelines may be summarized.