Payroll - Degraded Performance
Resolved·Degraded performance

Issue resolved.

Wed, Jul 20, 2022, 08:02 PM
(3 years ago)
·
Affected components
Updates

Resolved

Issue resolved.

Wed, Jul 20, 2022, 08:02 PM

Investigating

We are continuing to investigate this issue.

Wed, Jul 20, 2022, 07:59 PM

Investigating

Our payroll partner is currently experiencing degraded performance. We are investigating.

Wed, Jul 20, 2022, 07:58 PM
Powered by

Status updates are published by our internal monitoring and incident response teams. For questions, contact support through your usual channel. Historical data and incident timelines may be summarized.