Resolved
This incident has been resolved.
Investigating
We've identified a DNS issue from a downstream provider that is affecting many websites across the internet, ours included. This may result in slow response times, or pages failing to load entirely.
Status updates are published by our internal monitoring and incident response teams. For questions, contact support through your usual channel. Historical data and incident timelines may be summarized.