Customers seeing 404 errors and site slowness

Incident Report for Homebase

Resolved

This incident has been resolved.
Posted Oct 28, 2019 - 14:46 PDT

Investigating

We are currently investigating this issue.
Posted Oct 28, 2019 - 13:05 PDT
This incident affected: Web Application, iOS Mobile App, Android Mobile App, iOS Timeclock, Android Timeclock, Clover Timeclock, and Public API.