Timeclock Outage
Incident Report for Homebase
Resolved
This incident has been resolved
Posted Jul 12, 2024 - 08:23 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 12, 2024 - 07:33 PDT
Investigating
Homebase is currently experiencing an outage and some users are not able to clock in. We are actively investigating this issue. Please check back later or subscribe for updates on this issue.
Posted Jul 12, 2024 - 06:52 PDT
This incident affected: Web Application, iOS Timeclock, Android Timeclock, and Clover Timeclock.