Homebase Main Page Refresh Issue

Incident Report for Homebase

Resolved

We have resolved the issue that was impacting some of our users. We apologize or any disruption this has caused.
Posted Jun 16, 2025 - 10:16 PDT

Investigating

We have resolved the issue that was impacting some of our users. We apologize or any disruption this has caused.
Posted Jun 16, 2025 - 10:15 PDT

Identified

Our engineers have identified the issue. A preliminary fix was applied to resolve refreshing, and a permanent issue is now being deployed.
Posted Jun 16, 2025 - 09:26 PDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 07:28 PDT

Investigating

We are currently experiencing intermittent issues causing constant refreshing. We are actively working to resolve the issue and apologize for the inconvenience
Posted Jun 16, 2025 - 07:24 PDT
This incident affected: Web Application, iOS Mobile App, Android Mobile App, and Homebase Payroll.